ActivePresenter Saola Animate Pricing Download

Triggers on a Symbol Timeline not working

Hi.
I placed my random image generating code (Posted in an earlier thread) as a trigger in a symbol timeline but it does not work? I tried a “Pause Timeline” action on the same timeline and it does not work either. Is there something I need to do to enable Symbol Timelines to work with JavaScript it or could this be a bug?
Many thanks
Deek

Hi Deek,

Did you try starting your symbol by using the Adding Playback option in the Timeline pane or using action to trigger the symbol?
If you have tried but it doesn’t work as you want, please share the project so we can check.
You can attach it here or send it to support@atomisystems.com.

Best regards,
Thuy

Hello Phuong Thuy_Le.
Thanks for the response. I have sent a zip file with the project.
(Double click into the Symbol Timeline).
Yesterday this project was not working so this morning I added
a “Pause” Timeline Command after the JavaScript and it started
working??? I do not understand why it would not work without the
Pause Timeline command AFTER the JavaScript???
Please explain.

UPDATE: I just sent through 2 emails to support@atomisystems.com and they both bounced back?
I will attach it here.
RandomTestWorking.zip (270.4 KB)
Is this a Symbol Timeline Bug??

Many thanks
Deek

Please see attached same code works fine on the main timeline WITHOUT a pause.

RandomWorking2.zip (555.1 KB)

Cheers
Deek

Hi Deek,

Your zip files contains JavaScript files so they’re rejected by our email service provider.
Going forward, please click File > Save As > Package and share the package as I already mentioned in one of your topics.

We removed the Pause Timeline trigger in the symbol in RandomTestWorking project and it still works fine.
Can you please verify?
In addition, you should use a Start Timeline action for the button in the symbol. Timeline actions (start, play… timeline) provide better performance than the symbol actions (start, play… symbol)

This project also works fine, but you should take notice to some points below:

  • The main document Autoplay (in Document pane) is not checked, so its main timeline will not play. It’s not necessary to add a trigger at 0 to pause the main timeline anymore.
  • Press button handles both Mouse Down and Mouse Click event, you should remove one.
  • Play Timeline From 0 action (in Press button) has the same effect as Start Timeline action.
  • Start Symbol action (in Press button) doesn’t have any associated symbol (Maybe you deleted the symbol after adding the action)

Regards

Hi and thanks for looking at this.
I can verify that it’s working properly now :smiley:
The browser must have been playing out of cache as it definitely was giving me some strange results on playback this morning???
Very sorry for the confusion, also, I did not realize there was an option to “SAVE AS Package” in the main file menu.
New user mistakes.
Cheers
Deek