ActivePresenter Saola Animate Pricing Download

SVG import issue

Greetings!

I’m beginning to use Saola Animate (on Windows) and am having problems importing SVG in the document (for the record, I’m using v2.7.1).

The SVG imports fine in the Resources panel and also shows up fine in the browser. However, it doesn’t show up in my document workarea.

I’ve attached a screenshot for reference:

Please note that this problem for me is independent of SVG file, i.e., it’s happening to any SVG that I use.

Hi Hrishikesh,

Can you please check if the issue happens with png/jpg images, and this simple svg:
rectangle
Please also share the log file Saola Animate.log in the folder %APPDATA%\ATOMI\Saola Animate

Regards

Sorry, I forgot to mention, the PNGs and other formats work fine. But, I’d really like to use SVGs for small size and high quality.

Tried the SVG you provided, the result is still the same.

Here are the contents of the log:

2020-03-19T12:37:08 ===============  Saola Animate 2.7.1 (Released: 2019.09.18)  ===============
2020-03-19T12:37:08 OS: Windows 10 (10.0) x86_64 (10.0.18363)
2020-03-19T12:37:08 Host: AN515-52.
2020-03-19T12:37:10 libpng warning: iCCP: known incorrect sRGB profile
2020-03-19T12:37:32 Signing in...
2020-03-19T12:37:33 Sign-in completed.
2020-03-19T12:37:37 Registered new object after initialization, existing clients won't be notified!
2020-03-19T12:37:39 Checking updates for version 2.7.1 ...
2020-03-19T12:37:40 No updates available.
2020-03-19T12:37:43 Registered new object after initialization, existing clients won't be notified!
2020-03-19T12:38:27 Shutting down Saola Animate

I cleared the previous logs > re-installed Saola Animate after deleting all the previous folders, registry entries, etc. > Opened the program > Imported the SVG in the file > Closed it.

It’s so strange.
Unfortunately, the log file doesn’t provide any usefull information.
Can you please try the following steps to see if it works:

  1. Close Saola Animate.
  2. Delete Saola Animate folder in %LOCALAPPDATA%\ATOMI
  3. Restart your computer.
  4. Run Saola Animate again.

Regards

I’m sorry to say, there’s still nothing new in the log that’s going to help you, but, here it is:

2020-03-19T13:06:50 ===============  Saola Animate 2.7.1 (Released: 2019.09.18)  ===============

2020-03-19T13:06:50 OS: Windows 10 (10.0) x86_64 (10.0.18363)

2020-03-19T13:06:50 Host: AN515-52.

2020-03-19T13:07:06 libpng warning: iCCP: known incorrect sRGB profile

2020-03-19T13:07:48 Checking updates for version 2.7.1 ...

2020-03-19T13:08:10 Error connecting to the license server. Code:  QNetworkReply::NetworkError(TimeoutError) , Message:  "Socket operation timed out" 

Response:

 ""

2020-03-19T13:08:10 There was an error connecting to the license server. Code: 4. Message: Socket operation timed out

2020-03-19T13:08:10 Signing in...

2020-03-19T13:08:48 No updates available.

2020-03-19T13:09:10 Error connecting to the license server. Code:  QNetworkReply::NetworkError(TimeoutError) , Message:  "Socket operation timed out" 

Response:

 ""

2020-03-19T13:09:10 QWindowsWindow::setGeometry: Unable to set geometry 500x245+710+390 on QWidgetWindow/'SLSignInWindow'. Resulting geometry:  500x261+710+390 (frame: 8, 31, 8, 8, custom margin: 0, 0, 0, 0, minimum size: 500x245, maximum size: 16777215x16777215).

2020-03-19T13:09:10 Sign-in failed.

2020-03-19T13:09:12 Signing in...

2020-03-19T13:10:12 Error connecting to the license server. Code:  QNetworkReply::NetworkError(TimeoutError) , Message:  "Socket operation timed out" 

Response:

 ""

2020-03-19T13:10:12 QWindowsWindow::setGeometry: Unable to set geometry 500x245+710+390 on QWidgetWindow/'SLSignInWindow'. Resulting geometry:  500x261+710+390 (frame: 8, 31, 8, 8, custom margin: 0, 0, 0, 0, minimum size: 500x245, maximum size: 16777215x16777215).

2020-03-19T13:10:12 Sign-in failed.

2020-03-19T13:10:16 Shutting down Saola Animate

2020-03-19T13:10:19 ===============  Saola Animate 2.7.1 (Released: 2019.09.18)  ===============

2020-03-19T13:10:19 OS: Windows 10 (10.0) x86_64 (10.0.18363)

2020-03-19T13:10:19 Host: AN515-52.

2020-03-19T13:10:20 libpng warning: iCCP: known incorrect sRGB profile

2020-03-19T13:11:20 Checking updates for version 2.7.1 ...

2020-03-19T13:11:22 Error connecting to the license server. Code:  QNetworkReply::NetworkError(TimeoutError) , Message:  "Socket operation timed out" 

Response:

 ""

2020-03-19T13:11:22 There was an error connecting to the license server. Code: 4. Message: Socket operation timed out

2020-03-19T13:11:22 Signing in...

2020-03-19T13:12:20 No updates available.

2020-03-19T13:12:22 Error connecting to the license server. Code:  QNetworkReply::NetworkError(TimeoutError) , Message:  "Socket operation timed out" 

Response:

 ""

2020-03-19T13:12:22 QWindowsWindow::setGeometry: Unable to set geometry 500x245+710+390 on QWidgetWindow/'SLSignInWindow'. Resulting geometry:  500x261+710+390 (frame: 8, 31, 8, 8, custom margin: 0, 0, 0, 0, minimum size: 500x245, maximum size: 16777215x16777215).

2020-03-19T13:12:22 Sign-in failed.

2020-03-19T13:12:27 Signing in...

2020-03-19T13:12:28 Sign-in completed.

2020-03-19T13:12:34 Registered new object after initialization, existing clients won't be notified!

It’s so long because it took me multiple sing-in attempts to realise after restart my laptop wasn’t connected to the Wi-Fi.

Hi,

Did you delete Saola Animate folder in %LOCALAPPDATA%\ATOMI? This folder contains the folowing items:

I’m sorry but I just want to make sure you deleted the right folder.
You can aslo try disabling firewall and turning off antivirus/security software on your laptop temporarily, then restarting Saola Animate.

Regards

No, I deleted the one from here: C:\Users\<Username>\AppData\Roaming\ATOMI. It had a folder with the name Saola Animate which contained Saola Animate.log and Saola Animate.ini.

I have no antivirus or firewall except the default Windows security.

So you deleted the wrong folder. You should delete C:\Users<Username>\AppData\Local\ATOMI\Saola Animate

With a long discussion and remote sessions with support, I was able to fix this issue.

The problem was with an application I had installed a few months back on my laptop. Even though I had uninstalled the application, my system was broadcasting the mime type of SVG file as document/ConceptDrawDIAGRAM instead of image/svg+xml.

So, I had to go to Windows Registry, navigate to Computer\HKEY_CURRENT_USER\Software\Classes\.svg and changed the value of the key named Content Type to image/svg+xml.

Kudos to Atomi for the excellent support!

1 Like