ActivePresenter Saola Animate Pricing Download

Saola breakpoint glitches

My project : im doing a project that involves breakpoints, im using a html widget for reference, so i can later add the saola code inside mi website. (so the widget is not important in this case)

Here is my Problem: breakpoints sometimes glitch or dont work as expected as shown in the following video : https://youtu.be/h4upZScN4V8
in my last breakpoint i rotated the rectangle 30% while in all the others have 0%.

in the video you can see me testing the breakpoints, they work fine at first, but on 1:04 you will see that my project starts to fail and deform my elements randomly, and this is a big issue if someone is trying my website.

I dont really know if im doing something wrong…

Saola Animate version: 2.6.0

OS:Windows 7

Notes: In this test i just previewed the project, its the same when i export…yesterday i did the same thing in another video, but in this new one you can see better my issues.

Thanks.
Joe.

Hi Joelon,

Please attach your project so that we can check.

Best Regards,

look1.saolapack (443.7 KB)

So i investigated a little bit and i suspect there is a problem with animation override, the project is a bit chaotic since i was trying things out, im new to this, i apologise in advance.

The curious thing is that this deformations happen in browsers but not in the saola program.

if i know what really happened, i wont do this mistake again in future projects.

Thanks

Hi Joe,

When changing layouts in browsers, Saola Animate resets only properties which have been overridden in at least one layout, and run the timeline in the new layout.
In your project, Div_2 element doesn’t have Rotate Z property override in any layout, and has Rotate Z animation override (in the main timeline) in some but not all layouts. So Div_2 Rotate Z isn’t reset in layouts which don’t have Rotate Z animation override.

In the application, entire scene will be reloaded when changing layout so this issue doesn’t occur.

To reset Rotate Z for Div_2 element, you can do one of the following methods:

  • Remove Rotate Z animation override in all layouts, turn off Auto-keyframe mode, and change Rotate Z property in the smallest layout.
  • Or: Add Rotate Z animation override for all layouts.

Regards

Hello Saola team.

Toan Le, without your detailed explanation i would never had fixed this issue…you are awesome!.

Thanks.
Joe.