Mouse Click Interactions Not Working

Hello all :slight_smile:

I am trying to create a simulation (AP9) but none of the mouse clicks in my project seem to be working, neither the ones created automatically by AP while I was recording the simulation nor the ones I added manually where I had to insert screenshots on slides in between the recorded ones.

You can see in the screenshot that everything is set up here to work normally - automatically provided by the mouse click interaction. I have a target area on the new project icon, and the settings are there to show the correct and incorrect feedback as appropriate.

But as you can see in the shot below, when I click on the target area it is showing incorrect. I tried to upload a little clip, but you can get the idea from the image.

As I mentioned, this is happening whether these are automatically inserted clicks or whether I manually added them. Also, I have the clicks set to show in all four modes.

Clearly I must be doing something wrong but I don’t know what since these are inserted with default settings by AP.

Any ideas? TIA!


That seems odd.

Does the “Correct Value” listed in the General Section match the manner in which you clicked on that box?


Hi Gregs :slight_smile:

Yes, it does seem odd indeed, right? This is my first time doing simulations in AP (you may remember that I was until recently mostly a Captivate user) but I assume its a straight forward process.

Yes, the correct value was listed as Left click (which is one tap on my trackpad) and when it didn’t work first I added Right click as a correct value as well just in case. Still no go :frowning:

I don’t know what the issue could be…


Ok, just out of curiosity I added a fill to the click box and then turned the opacity down to nothing so it’s still transparent and it worked.

So…is that the issue? I would have expected that the mouse click as an interaction inserted would work with the default setting (which is with no fill it seems).

If so, do I have to go through every slide and change the box? Is there a faster way…?


1 Like

The interaction worked fine for me the first time.
No need to add a fill.

I see that you are on a Mac. (Correct me if I am wrong)
I wonder if is one of those anomalies between Mac and Windows…?

Perhaps it works fine on another version…?

I am not sure of a faster way across multiple slides but you should be able to select each box on a slide if more than one and change them all at once.

**Edit - I wonder - for testing purposes, if Mac views the non-fill box as open rather than transparent. What if you tried to click exactly on the line of the box without fill?

Hi Greg;

Thanks again, as always, for your speedy reply :slight_smile: - you are super!

Yes I am on a Mac, but I just tried again with a blank project based on no template or anything and it worked just fine with no need to add a fill, so I’m not sure what the issue is with my first project :woman_shrugging:t2: because it’s literally every single mouse click. I will try again (with a shorter project tester) using the template that we’ve set up to see if there is some issue there.

In the meantime, it does seem that I can use the format painter between slides so that should cut down my work time to add the oddly required fill to those boxes for this project.

Thanks again, Greg!


**Edit for your edit - I did try to click exactly on the line of the box and it still didn’t help. It was at that point that I reached out to the community here because I didn’t know what else to do. I couldn’t imagine that a fill was necessary, but I’m glad I didn’t try that before reaching out, otherwise I might have thought it was!

1 Like

Glad you got it figured out.

Sometimes it just helps bounce things around together with someone.

1 Like

So true @gregs :slight_smile: thanks again!


Hi all,

The mouse click function should work under these settings:

It’s quite unusual that this issue arises with ActivePresenter’s default settings. Therefore, I suspect there may have been some unintentional modifications that led to the issue. Otherwise, it could be a software-related problem. In that case, please provide us with your sample project and the ActivePresenter log for further investigation.

Additionally, I’d like to clarify a bit more about the Opacity function in ActivePresenter:

The software detects mouse interactions based on the object’s shape. Consequently, if there’s No Fill or No Line at all, it doesn’t recognize the shape, resulting in the mouse not being captured.
If you prefer not to see the shape at all, you’ll need to apply either Fill or Line (for shapes with closed lines) and set the Opacity to 0. This can be adjusted either for the object itself or for the Fill/Line color.


Hi @Hang - thank you so much for weighing in here. Thanks to your message, I believe I understand the issue. I went into the template that our company has made and noticed that when we created it we made the mouse click object settings to be both no fill and no line. Based on your last paragraph I feel confident in saying that it is user error rather than any software issue.

Thanks again for your information and for your help in clearing things up!


Thank you @samamara for clarifying matters, and I’m glad that the information I provided has helped resolve the issue for you. If it’s related to the object settings in templates created by your company, you can adjust the mouse click settings there. This adjustment will then apply to all mouse click objects in the newly created projects afterward.

Please feel free to ask questions or engage in discussions within this community to enhance your understanding of ActivePresenter.

Have a nice day!

1 Like

Thank you @Hang :slight_smile: you have a great day too!