Default Slide from Template for Simulation

Hi all;

I have a question about recording simulations and setting a default slide for them. Our company has an ActivePresenter template designed with several slide types, including a blank slide.

When I click Insert > Record Interactive Simulation, the simulation slides are recorded on a slide that has placeholders. The result is that I have to go through all of my slides to remove the placeholders, which is time consuming.

So I’m wondering if:

  • there is a way to set a blank slide as the slide AP uses to record simulations on, and/or
  • it’s possible to bulk delete those placeholders (I don’t see them as an option in the normal Project > Batch Operations > Delete Objects area).

If anyone has any ideas, I’d appreciate it. Some of my simulations are very long and it’s a tedious and time consuming task to go through and remove all of those placeholders (that do show in the output, in case you’re wondering).


I was not able to replicate what you are describing.
Admission - I don’t happen to have any templates other than those provided.
…but I did make a blank one and save it as .apslide

I created a project with a blank slide, a slide with placeholders, and I tried using one of the built-in design themes with placeholders.

In each case listed above - my recording was added to a new set of slides without any placeholders.

If you tried a short recording with just a click or two with a native design - do you still experience the same?

From a troubleshooting standpoint - I am looking to isolate if it stems from the template itself - or… perhaps if you see it all the time… is it a Mac thing…?

Hi @gregs - thanks so much for getting back to me on this. I’m don’t know what the issue is, but I feel it’s something to do with our template. Have a look at what I mean with the placeholders. This is our template master, where you can see the placeholders:

And here is what I am getting every time I go to Insert > Record Active Simulation, the placeholders are on every single slide, which as I’m sure you can imagine is frustrating:

After reading your message, I opened AP and just clicked on one of the templates provided, did Insert > Record Active Simulation again, and it worked fine (I tried with two templates actually):

So just to test an idea that the simulation takes the first layout or something, I went back to our work template and inserted a blank slide as the first slide layout (even though we have a blank slide near the bottom of the master deck) and tried Insert > Record Active Simulation again. Thankfully it worked!

That was so great to see because short-term it solves a big problem for me (which thankfully is not a Mac thing it seems), but it does raise questions:

As I said, I was thinking maybe the simulation takes the first slide in the deck, but the other templates don’t have a blank layout as their first slide, so I’m not sure why adding a blank slide to our template master deck worked…?

Secondly, you mentioned that you created a template and saved it as .apslide. I didn’t make our template but I don’t think the person who did saved it as such since it’s an .approj file. Do you think that could be the issue?


Edit: I just quickly opened the template we have (.approj) and did Save As > .apslide, then clicked on Insert > Record Active Simulation but got the same thing:

So I’m not sure at all at this point :frowning:

When you did your save as .apslide - did you save it to this location?

/Users/<user_name>/Documents/ActivePresenter Templates
(for macOS))

If you do it should be found under custom when you launch at the startpage


See article below.

Hi again :slight_smile:

No, I had not done that but I just did and found it in Custom so that part is good. But I tried a quick simulation recording and, sadly, the same thing happened:

Weird, right?

Yeah - You said that you had a blank slide in the template deck?


Yes, in the original template deck there is a blank slide, but it’s down quite low under all the other slide layouts. I added another and made it the first slide in the deck, and that’s when the simulation stopped adding the placeholders.

Again, though, the other templates don’t have a blank slide as the first one, so I’m not sure why that worked for me…?

OK - So have we arrived at a solution, then?
You save your template with a blank at the beginning and it is good?

Yes, I guess we have. Adding that blank slide at the top of the master deck worked, but I’m not sure why and it just leaves me with a nagging feeling that something is wrong with our template. That said, nothing else has gone awry, so fingers crossed this is it!

Thanks @gregs for all your help!


Hi all,

For the slides that have already been captured, you need to use SHIFT Click to select all the captured slides in the Slides pane.
Then, right-click and select Layout > your blank layout.

The principles for choosing a slide layout when capturing are as follows: ActivePresenter looks for a layout named Blank. If this layout does not exist, the first layout is selected.

In your case, the Blank layout in your template has been deleted, then the first layout will be selected by default.

Now you just need to rename the layout that you are using as the blank layout (the one with no placeholders, but which you haven’t named “Blank”) to Blank (Right-click > Rename Layout ).

Hope this helps!


Hello Hang;

Wow…the amount of work you have just saved me for the slides that I have already captured!! You are amazing :star_struck:!

The fact that AP is looking for a slide named Blank makes a lot of sense to me now. I guess there is not one with that name in our template, so it just took the one that was there first, which is why I got all those placeholders (as the first slide in the deck had them). I guess, too, that’s worked when I put a blank slide at the top of the deck. It wasn’t named Blank but was blank lol.

I will fix the issue immediately.

Thanks again @Hang!

1 Like

That was the screenshot of the blank layout I asked about. Sorry for not being more clear about that.

Oh, sorry @gregs - I didn’t get your point at the time. It was early morning here and I was thinking about all the work I had ahead of me to delete all those placeholders!

Thanks again for all your help as always :slight_smile: