ActivePresenter Saola Animate Pricing Download

Azure TTS Authentication Error

Problem: Cannot get Microsoft Azure TTS integrated with ActivePresenter 8.1.

ActivePresenter version: 8.1

OS: Windows 10

Notes: I have been able to integrate Amazon Polly and Google Cloud TTS engines with ActivePresenter but Microsoft Azure Test Authentication is returning a Resource not found authentication error. When I attempt to save, I get the following error message: Error while getting Microsoft Azure voices: The request is not authorized. I have tried both Azure subscription keys, my Azure account is active, and I am in the correct region, but no success. Please advise.

Thanks!

Hi Scott,

Please send us the log file of ActivePresenter. We will check the problem and get back to you.

Regards,

Thanks Nam,
I was able to connect using the following Endpoint:
https://eastus.api.cognitive.microsoft.com/sts/v1.0/issueToken

for eastern US time zone.

The endpoint that was automatically assigned in my Azure account did not work.

So this issue is resolved.

Best,
Scott

1 Like

That sounds good, Scott. If you have any questions, please let me know.

Regards,

The TTS endpoint must be in the format https://<REGION_IDENTIFIER>.api.cognitive.microsoft.com/sts/v1.0/issueToken

I note here to help other users if they have the same problem.

Regards

Please help! I have the same problem, however I have definitely entered the correct endpoint etc in the correct format. My end point selection field is a drop down so have tried just selecting the “australiaeast” one but that isn’t working either?

ActivePresenter log file.txt (14.5 KB)

Hi noma_j,

In the latest version of ActivePresenter, you have to select the correct Azure Region (instead of endpoint). Could you check this information again?

FYI, if your endpoint is https://eastus.api.cognitive.microsoft.com/sts/v1.0/issueToken, the region will be eastus.

Regards,

Yes, I have definitely selected the correct region.

Hi noma_j,

Currently, we still have not found the cause of the problem. Is it possible for me to look at your computer via remote control (such as Teamviewer)? If yes, you can send the credentials information to our support email support@atomisystems.com.

Regards,