Audio delay on xAPI

Problem: When closing and restarting a course that has already been started, the audio track is played too late and the first syllables or word is cut off.

I close a course I have already started and the last page I visited is accessed.

Expected Behavior:
The corresponding page starts over and the voice over starts over.

The page restarts, but the voice over is cut off at the beginning, so the first syllables or word is not played back.

ActivePresenter version: 9.09 / 9.1.0


This affects all popular browsers (safari, Chrome, Firefox, Edge) - it is NOT LMS related, as external courses made with different authoring tools (isEazy, etc.) work properly without any audio bug.

Hi Jens,

Thank you for letting us know about the issue.
For your information, most browsers don’t allow playing unmuted audio/video without user interaction first. So, it may cause your issue.
Kindly see the Autoplay policy of browsers here: Autoplay policy in Chrome - Chrome Developers

The best practice to overcome this issue is inserting a button on the first slide. The user must click on that button to start the course.
You can clear Disable [Click or Tap to Unmute] Notification check box on the Export to HTML5 dialog to remove the message. Then, you can insert a shape (along with the button I mentioned above) for your own message if it’s necessary.

Hope that it clarifies.

thanks for the reply.

I have already done that to overcome this problem when first starting the project.

BUT this does not solve the problem for the case a user starts the course, stops somewhere in-between the ILC and get back to that slide again later. → THEN the problem also occurs. :frowning:

I would need a solution for this as well, as I have no clue how to overcome that issue.

and it happens in all browsers (Safari macOS, iOS, Edge, Chrome, Firefox)

Hi Jens,

It seems that you’re opening a project created in ActivePresenter 8. And there is no option to decide whether to restart or resume the presentation when go back to it.
Just click the ActivePresenter button > Project > Properties.
Then, navigate to the Properties pane > Interactivity tab and add the Show Feedback Layer: Resume Feedback to the project On Load event.
See the image below for details:



1 Like


sorry for not replying in time. Will try that and will report back if this fixes the problem!

Thank You so far. I greatly appreciate the support of atomi! :+1:


Works for me here for all browsers

Thanks for the workaround! :+1: :blush:


Thank you for getting back to us, Jens.
Nice to know that your issue has been resolved :blush:

Feel free to let us know if you need any further assistance.
Nice day.