Video inside HTML5 simulation

Problem: Hi! When I play my HTML 5 simulation containing 2 mp4 videos on separate slide, the videos load and play almost every time, but sometime they won’t start. If I use the menu to come back to a video, it never starts.

ActivePresenter Version: 6.0.3

OS: Win7 IE 11

Notes: I’m in a large business, so I don’t have any other browser. When I try the file directly on my computer, it seems to always work. I think it might be a server/cache problem. Is there a place I can see trouble with AP?

Hi SimonA,

We have checked but could not reproduce the problem in our tests. Can you please share the project file and its external data folder named in the pattern PROJECT_FILE_files if any so we can analyze further? You can upload files to Google Drive or something like that and send the link to us at


Hi, I can’t upload a file this size from my work. I’ll do it tomorow from home.

For now, as you can see in the picture provided from Network analysis from IE, the res_10088.mp4 load the first time I saw it, but when I returned, it only gets 489 B and a 304 GET result. The timeline in my simulation worked, but no video played.

It only happens when I call the simulation from a distant server (http:// blabla). When I go directly to the server \serverblabla, it always works.

Hi Simon,
From your log, this seems to be an issue with the web server instead. IE complains about unknown MIME type for mp3 and mp4 file.
Please define additional MIME types for mp3, mp4 on the server and try again to see if it works.
Adding MIME types depending on your webserver, if it’s Apache then simply add below lines to your Apache config file:

AddType audio/aac .aac
AddType audio/mp4 .m4a
AddType audio/mpeg .mp3
AddType audio/ogg .oga .ogg
AddType audio/wav .wav

AddType video/mp4 .mp4 .m4v
AddType video/ogg .ogv
AddType video/webm .webm

If you’re on IIS or nginx then you can google for how to add MIME types.

Best Regards,


I have exactly the same problem like Simon had (Mime-type Error while starting the videos with the menu). But I use a SCORM 1.2 package and I have no idea how to add MIME types in our (very restricted) company. I suppose, it’s impossible. :frowning:

I suppose, that Internet Explorer 11 doesn’t understand the HTML5 MIME-types, which are used, but we still have to work about 6 months with IE 11 before getting an update on Edge.

Do you have any idea for a workaround?

ActivePresenter Version: 8.2.2
OS: Win10 IE 11

Thank you very much in advance.

Best regards,


IE11 should not be the cause of problem. You can upload a test sample to this site then open the course in IE11 to see if it works.



thank you for your fast response.
Yes, you are right. I tested the course on another web server and opened it with IE11 without any problems.
So, where is the problem? The SCORM-Container, our LMS? What do you think?


It seems to be a server configuration issue. Contacting your site administrator for help seems to be the best option.


Hi! I work in a restricted organisationnal environnement too and, as Phuongdv suggest, I contacted the server admin and they configure the IIS server with the correct mime type. After that, it worked.

Thank you!
I also contacted our server admin. It will need some days to add the MIME-types but it is possible :slight_smile:

thank you very much!

1 Like