Unable to delete range after upgrading to v7.2.3 & everything is slow

Problem: first video recording with version 7 and there are some issues:

  1. unable to delete range (auido/video) from project with 792x514 resolution;
  2. everitihing works slower:
    a) naming a project: couple of minutes (5+ minutes), compared to version 6 that was less than a minute
    b) after recording ~70minutes and ctrl+end i have to wait 2-3 minutes to see the project, compared to ~5-10 seconds with version 6.
  3. for ~90minutes of recording uses a space of around 20Gb in C:, where i have limited space (~20Gb) and although i moved projects’s path to D:\ActivePresenter the program uses a “temp folder” somewhere in C:, because it crashes and i find C:\ partition maxed out. Please help me by telling me how to find this “temp folder” from C:\ in order to recover a recoding (i’ve checked hidden files in “C:…\Documents\ActivePresenter…hidden folder” and is missing and C:\ partition is still full after last recording)
    Is there any way to change recording folder from C:\ to another partition?
    After 3rd issue i understand 2a issue: the temp project was saved in C:\ and the program had to move it in D:, where i save Atomi projects.

ActivePresenter Version: 7.2.3

OS: Windows 8.1

Notes:
Started project as untitled and saved-it with a friendly name then tried to edit the project.
Using free version.

Hi,

We have checked but could not reproduce the 1) issue. Does it happen with other project dimensions or only this one?

For 2) 3), please do following steps as a workaround:

  • Open file C:\Users<User_Name>\AppData\Roaming\ActivePresenter\ActivePresenter.apconfig
  • Add the pair of key and value: “tempdir”: “D:\temp\”, at the second line (note the comma at the end)

Regards,

“could reproduce” or |could NOT reproduce| the 1) issue?
Tested now:
full screen = ok
801x600 = ok
792x514 (again) = ok
920x514 (again) = ok

I have 2 projects with 920x514 that has this issue and can work with. I am unable to find 792x514 because i have lots of projects to review.

Thank you, found temp dir and deleted 10+Gb. Unable to understand how could i use those files to put them in a project so i recorded the webinar again. This issue is for another time.

I could edit “ActivePresenter.apconfig” and when v7 starts “ActivePresenter.apconfig” is reset to default and capture is recorded in “C:…\AppData…\temp”

I had many atempts
“tempdir”: “D:\temp” (as in example)
“tempdir”:“D:\temp” (tried witout space")
“tempdir”:“D:\ActivePresenter\temp” (another folder, already created)

Example .apconfig (commas are copied from within .apconfig)

{
“tempdir”:“D:\temp”
“capture.locktoapp”:“false”,
“config.version”:“7.0.0”,
“capture.area.show”:“true”,

Hi,

You missed the comma after that added line, it should read:

{
“tempdir”:“D:\temp”,
“capture.locktoapp”:“false”,
“config.version”:“7.0.0”,
“capture.area.show”:“true”,

Also remember to close ActivePresenter before making changes to the config file.

Regards,

I’ve put the comma | “tempdir”:“D:\temp”, |
I get an error message (see picture) and .apconfig returns to original.
I’ve manually added “temp” directory to D:, same error.

.Error

My mistake!
You should escape the backslash character too.
So it should read:

{
“tempdir”:“D:\\temp”,
“capture.locktoapp”:“false”,
“config.version”:“7.0.0”,
“capture.area.show”:“true”,

Regards,

Hi @Valentin_Nicolae_Geo,

Can you please share the project file which has the issue (Delete Range) so we can analyze further? Please also share its external data folder named in the form PROJECT_FILE_files if any. If these files are large, you can upload it to a cloud storage site like Google Drive and send the link to us.

Regards,

Works perfectly :slight_smile: Thank you
Changed the line a bit and everything is perfect

I’ll upload them in the evening, files size is 12Gb and have to transfer them to an NAS.
As a personal note, why so huge? Previous versions were under 2Gb with similar projects :slight_smile:

Please try to reduce its size by clicking ActivePresenter > Project > Shrink, check Delete All Unused Resources then click Shrink.

Done. Size remains the same, 12 Gb, and the shrinking process was less than 1 sec
I’ll upload files on NAS in the evening

Hi,
You will find 4 ActivePresenter projects [Censored_URL].
They are sorted in 3 folders, captured with different program versions.

I’ve put you so many projects because the issue is awkward. Let me explain.
I’ve experienced “unable to delete range (audio/video)” with all 4 of them, BUT not all the time :sweat_smile:
Now, when i write this, only 2 projects have this issue and the other two are editable. Unable to find a connection.

  • v4.0.3 --> “Razvan Cazanescu - 40 de lectii…” issue with both programs v4 and v7 (project created in v4 due to “tempdir” autoset in C:\ and limited space there) [this bug was screencaptured in my previous post]
  • v7.2.3 --> “Razvan Cazanescu - 5 motive” issue with v7 (project created in v7)
  • other 2 projects are editable, now…

If you need other files from the programs installed (4.0.3 & 7.2.3) let me know.

Aditional question: why 2 similar projects created with v7 have a so different sizes: 1.3Gb vs. 12GB?
And an info: as i validated the issue, ActivePresenter v7 crashed while editing the project in “v6” folder, without any message or error, simply silently ended.

Have a excelent day :slightly_smiling_face:

Thank you for sharing the files.
We’ll take a look and let you know.

P/S: Please consider carefully before sharing your projects publicly as they may contain confidential information. Next time, you can send to our support@atomisystems.com.

Regards,

Thank you for your thought.
They are free online trainings without copyright & confidential issues but i’ll note the e.mail address for another time, if it will be something private.

Best wishes

Hi @Valentin_Nicolae_Geo,

  1. Delete Range: We have seen that you have locked all objects (the Lock icon on the left of Timeline) in the slide so the Delete Range command was inactive. Unlocking one of them will resolve the issue.

  2. The 12GB video uses a lossless video codec (Flash Screen Video) so the compression ratio is lower than the 1.3GB video which uses a lossy video codec (MPEG).

  3. We can edit the v6 file without crashing. Can you please describe the steps to reproduce the issue?

Regards,

  1. Thank you, such a simple solution. Note though that AC sometimes locks audio/video automatically when opening a project.

  2. How can be controlled what video codec to use? In both projects was the same resolution, same behavior in using AC7, same everything and different result.

  3. I remade the steps and worked perfectly now. Steps made:

  • check if delete range is possible (select a random range)
  • edit by deleting the final minutes in the project
  • started to select range from minute 0 to minute 1 let’s say, and program ended silently, with the icon near the clock also gone (usually stays until you move cursor over it)

An excellent morning :blush:

For controlling codec, please take a look at this article: https://atomisystems.com/tutorials/ap7/working-recording-settings-dialog/

Regards,