Sound does not record with video on MacOS Mojave

Problem: Built in mic is not being recorded with on-screen video.

I have just upgraded to a new operating system, MacOS Mojave and I have noticed that I can’t record a built-in microphone with ActivePresenter. It worked fine on MacOS High Sierra before.

I don’t see an audio wave at all when recording. It does not show on the timeline after recording in the editing mode, and the calibration does not show the sound wave either.

At the same time, I can record sounds using an internal microphone just fine with any other software, so I know it is not related to my computer. I must be something within the ActivePresenter that happened after updating to a new operating system.

I have emailed the log along with screenshots to Atomi support email. Any suggestions or workarounds will be greatly appreciated.

Thank you.


ActivePresenter Version: 7

OS: Mojave

Notes: AP does not record built in microphone when doing screen recordings.

Thanks for reporting the issue.

We will check and get back to you as soon as possible.


Hi Renia,

We have checked but it still works well on our macOS Mojave. So we need more time to find out the cause problem. Can you please let us know the configuration of your MAC?


Thank you so much for looking into that. Below are the details.

Hardware Overview:

Model Name: MacBook Pro

Model Identifier: MacBookPro11,4

Processor Name: Intel Core i7

Processor Speed: 2.5 GHz

Number of Processors: 1

Total Number of Cores: 4

L2 Cache (per Core): 256 KB

L3 Cache: 6 MB

Memory: 16 GB

Boot ROM Version: MBP114.0184.B00

SMC Version (system): 2.29f24

Serial Number (system):

Hardware UUID: 25B960FE-E29F-5087-8967-5B600EE9DF5B


Built-in Microphone:

Default Input Device: Yes
Input Channels: 2
Manufacturer: Apple Inc.
Current SampleRate: 44100
Transport: Built-in
Input Source: Internal Microphone

Built-in Output:

Default Output Device: Yes
Default System Output Device: Yes
Manufacturer: Apple Inc.
Output Channels: 2
Current SampleRate: 44100
Transport: Built-in
Output Source: Internal Speakers

I tried to uninstall AP and installed it again but the same issue persists.

I am including screen shots in case this might help. The mic icon is green but there is no graphical representation of wave at sound calibration.

Sound recording works fine with any other application and unfortunately, I can’t figure it out with AP.


Thanks for your information. We are looking in to this problem. Hope we will find the cause of issue soon.



Can you please check to see if ActivePresenter is enabled for accessing Microphone or not by the following steps:

  • Open Systems Preferences.
  • Click Privacy.
  • Select Microphone in the list on the left.
  • Make sure that ActivePresenter is selected.



That solved it! It works now!
I can’t believe I overlooked that.
Thank you so much for your help and for such excellent customer services.