Preview not working on some computers

Problem: On some computers preview works fine: the link uses http. (e.g. http://localhost:13536/1670922824287/demo.html). But on other computers, it fails since the link starts with https. When you remove the s (http://…) the preview works again.

Where is the behaviour defined whether the preview via localhost is using http or https? I could not find any corresponding entry in the ActivePresenter settings.

The internet options of the PC? But where?

Thanks a lot in advance for any hint,
best regards,

ActivePresenter version: 9:0.4, 8.5.1

OS: Win10 Prof


Hi Martin,

Thank you for your report. Seems it happens only on some specific computers.
Could you please help us check the problem with this build?


Hi Nam,
I can’t download the setup, it is blocked by our company firewall.
On the other hand, there must be a more generic root cause, since the same problem occurs with V8.5.1 (which is currently rolled out in our company). I realized the problem when preparing the change to V9.0.4. What else can I do?

Hi Martin,

We have just shared the test version again via email.
Please help us to check and let us know the result.

Thank you for your patience.

Best regards,

Hello together,
I could download ActivePresenter_v9.0.5_r30612_setup.exe and we installed it on one the failing PCs.
The result was the same:

Then we ran test (start active presenter, create new project from template, start preview) again with increased log level.

The resulting logfile is this:
ActivePresenter_Binger_V9.0.5.log (8.8 KB)

Hope this helps,
best regards,

Hi Martin,

Thank you for your information.

It seems the problem related to HSTS setting in Chrome. It automatically redirects http://localhost to https://localhost which causes the issue.

Can you please follow the steps in this video to check:

Best regards,

It worked for one of the test PCs. I have to test it with the others, too. But they are not available before Monday.
Thanks a lot for your quick support.
Best regards,

1 Like