Error while converting closed captions to Audio, Do you want to abort?

Problem:

ActivePresenter version: ActivePresenter Pro Edition
Version 8.3.2 - 64-bit build. (Released: 2021.01.26)

OS: Windows 10 Pro

Notes: Error while converting closed captions to Audio, Do you want to abort?
This the reply or the issue which pops up every time i try to convert the text to voice,
This makes really annoying to use this software,
The text to speech is the main reason i purchased this software and it hardly works.

Please can you let me know the solution for this.

Hi,

I’ve answered your question via email. It is a known issue when converting many CCs with Azure TTS. We will fix it in the next release.

We are sorry for the inconvenience.

Regards,

Hi there

I am experiencing this now. As far as I can tell, the conversion works for the first slide then the rest don’t convert. Is there some way of reviewing the log so I can work out why it is happening to fix it?
Thanks!

Hi,

Please send us the log file. You can find the log file by going to PreferencesMiscellaneousView Log button.

Regards,

Thank you. I have narrowed down the error to work out it only affects one slide. The log says…

2022-03-02 11:23:35: Preparing to play audio to: Speakers (Realtek(R) Audio). Channel: 2. Sample rate: 44100. Sample Format: 8
2022-03-02 11:23:36: Audio frames decoding started.
2022-03-02 11:24:34: Azure Text-to-Speech message: An error occurred while parsing EntityName. Line 1, position 120.
2022-03-02 11:24:34: Error while start speaking text
2022-03-02 11:24:50: Azure Text-to-Speech message: An error occurred while parsing EntityName. Line 1, position 120.
2022-03-02 11:24:50: Error while start speaking text
2022-03-02 11:24:58: Azure Text-to-Speech message: An error occurred while parsing EntityName. Line 1, position 120.
2022-03-02 11:24:58: Error while start speaking text
2022-03-02 11:30:19: Azure Text-to-Speech message: An error occurred while parsing EntityName. Line 1, position 120.
2022-03-02 11:30:19: Error while start speaking text
2022-03-02 11:30:30: RLMedia: Using AVStream.codec to pass codec parameters to muxers is deprecated, use AVStream.codecpar instead.
2022-03-02 11:35:48: Azure Text-to-Speech message: An error occurred while parsing EntityName. Line 1, position 120.
2022-03-02 11:35:48: Error while start speaking text

I am using the exact same “voice” on all the other slides and can’t work out why this slide is troublesome? Thank you for investigating for me!

Hi,

Could you show me the SSML text that you are using? I guess the problem comes from the SSML format.

Regards,

I have unticked SSML for all nodes. The text for each node is: 4
00:00:31,303 → 00:00:34,303
A Imdex reconhece que a saúde e o bem-estar de seus trabalhadores são primordiais para alcançar o sucesso.

5
00:00:37,917 → 00:00:40,917
É por isso que dispomos de ferramentas para ajudar a gerenciar os riscos à saúde e ao bem-estar de nossos trabalhadores.

6
00:00:44,733 → 00:00:47,733
Esta lição cobre os seguintes tópicos:

7
00:00:48,824 → 00:00:51,824
Avaliações pré-emprego

8
00:00:53,236 → 00:00:56,236
Drogas & Álcool

9
00:00:57,226 → 00:01:00,226
e trabalhando em condições extremas.

10
00:01:01,280 → 00:01:04,280
Vamos começar!

I have also tried using different “voices” and that isn’t helping. I have recreated the slide from scratch twice and that also doesn’t help. Thank you for your assistance!

Hi,

We’ve found that it is a bug if the text contains some special characters (such as &, <, >, ', \).
We will fix it in the next update.

In the meanwhile, please replace the & character with &amp; to resolve the problem.

Regards,

THANK YOU! I removed the ampersand character and replaced it with the word in full and it works perfectly now. Thanks so much!

1 Like

Please be informed that the problem was fixed in the ActivePresenter 8.5.5 version.

Regards,